VPIM

Uses your system voice; voice and rate in settings.

Snapshot

≈ 4 min read

Names in other languages

No names in other languages are held for this entry yet.

Article bodies are English and are not machine-translated. A name in another language is not a translation of the article.

Voice Profile for Internet Mail (VPIMv2) is defined in RFC 3801, an Internet standards track protocol. VPIM defines a subset of the Internet multimedia messaging protocols (MIME) for use between voice processing server platforms. This and related protocols define the familiar myEmailAddress@myDomain.com type of e-mail addressing everyone now uses on the internet, extending it from regular e-mail to voice mail and fax systems. RFC 3801 refers to other RFCs for details on addressing [RFC 3804] and [RFC 3191], FAX [RFC 3192], and GSTN Address Extensions [RFC 2846]. These RFCs are mostly concerned with e-mail address formats, dividing addresses into left hand and right hand sides (LHS, before the @, and RHS, after the @), how protocols are extended to support voice messaging, faxes, and AMIS addressing (which supports phone number dialing), and how to register new values of GSTN service selectors VPIM, VOICE, AMIS, and SYSNUM with IANA, the Internet Assigned Numbers Authority. The RFCs define VPIM gateways to "translate between dissimilar environments." Both "onramps" (gateways which connects from another voice mail networking protocol to VPIM) and "offramps" (gateways which connect from VPIM to another voice mail networking protocol) are defined, casting VPIM as the inter-system "highway" that connects the different voice messaging systems together.…

Voice Profile for Internet Mail (VPIMv2) is defined in RFC 3801, an Internet standards track protocol. VPIM defines a subset of the Internet multimedia messaging protocols (MIME) for use between voice processing server platforms. This and related protocols define the familiar myEmailAddress@myDomain.com type of e-mail addressing everyone now uses on the internet, extending it from regular e-mail to voice mail and fax systems. RFC 3801 refers to other RFCs for details on addressing [RFC 3804] and [RFC 3191], FAX [RFC 3192], and GSTN Address Extensions [RFC 2846]. These RFCs are mostly concerned with e-mail address formats, dividing addresses into left hand and right hand sides (LHS, before the @, and RHS, after the @), how protocols are extended to support voice messaging, faxes, and AMIS addressing (which supports phone number dialing), and how to register new values of GSTN service selectors VPIM, VOICE, AMIS, and SYSNUM with IANA, the Internet Assigned Numbers Authority. The RFCs define VPIM gateways to "translate between dissimilar environments." Both "onramps" (gateways which connects from another voice mail networking protocol to VPIM) and "offramps" (gateways which connect from VPIM to another voice mail networking protocol) are defined, casting VPIM as the inter-system "highway" that connects the different voice messaging systems together. Messaging and voice messaging systems such as Microsoft's Exchange, Cisco System's Unity and Unity Connection, and Callware's Callegra.UC product lines provide VPIM gateways with on and off ramp gateways to allow integration of similar and dissimilar messaging systems.

References

External links

Vaudreuil, G. and Parsons G. (June 2004) RFC 3801: "Voice Profile for Internet Mail - version 2 (VPIMv2)" Retrieved on 2008-March-26 Parsons, G. (June 2004). RFC 3804: "Voice Profile for Internet Mail (VPIM) Addressing" Retrieved on 2008-March-26 Allocchio, C. (October 2001) RFC 3191: "Minimal GSTN address format in Internet Mail" Retrieved on 2008-March-26 Allocchio, C. (October 2001) RFC 3192: "Minimal FAX address format in Internet Mail" Retrieved on 2008-March-26 Allocchio, C. (June 2000) RFC 2846: "GSTN Address Extensions" Retrieved on 2008-March-26

Text derived from https://en.wikipedia.org/w/index.php?oldid=1089775949 under CC BY-SA 4.0; modifications have been made.

Provenance

snapshot enwiki-001089775949 · captured 1653485586.0 · version history

Cite this page as: encyclopegia.org, “VPIM”, snapshot enwiki-001089775949. https://encyclopegia.org/a/vpim

Sources cited in this revision

Extracted from the cited revision's reference blocks; absent citations are not invented.