Lesson plan

VPIM

Voice Profile for Internet Mail (VPIMv2) is defined in RFC 3801, an Internet standards track protocol. VPIM defines a subset of the Internet multimedia messaging protocols (MIME) for use between voice processing server platforms. This and related protocols define the familiar myEmailAddress@myDomain.com type of e-mail addressing everyone now uses on the internet, extending it from regular e-mail to voice mail and fax systems. RFC 3801 refers to other RFCs for details on addressing [RFC 3804] and [RFC 3191], FAX [RFC 3192], and GSTN Address Extensions [RFC 2846]. These RFCs are mostly concerned with e-mail address formats, dividing addresses into left hand and right hand sides (LHS, before the @, and RHS, after the @), how protocols are extended to support voice messaging, faxes, and AMIS addressing (which supports phone number dialing), and how to register new values of GSTN service selectors VPIM, VOICE, AMIS, and SYSNUM with IANA, the Internet Assigned Numbers Authority. The RFCs define VPIM gateways to "translate between dissimilar environments." Both "onramps" (gateways which connects from another voice mail networking protocol to VPIM) and "offramps" (gateways which connect from VPIM to another voice mail networking protocol) are defined, casting VPIM as the inter-system "highway" that connects the different voice messaging systems together.…

Back to article

Article summary

Voice Profile for Internet Mail (VPIMv2) is defined in RFC 3801, an Internet standards track protocol. VPIM defines a subset of the Internet multimedia messaging protocols (MIME) for use between voice processing server platforms. This and related protocols define the familiar myEmailAddress@myDomain.com type of e-mail addressing everyone now uses on the internet, extending it from regular e-mail to voice mail and fax systems. RFC 3801 refers to other RFCs for details on addressing [RFC 3804] and [RFC 3191], FAX [RFC 3192], and GSTN Address Extensions [RFC 2846]. These RFCs are mostly concerned with e-mail address formats, dividing addresses into left hand and right hand sides (LHS, before the @, and RHS, after the @), how protocols are extended to support voice messaging, faxes, and AMIS addressing (which supports phone number dialing), and how to register new values of GSTN service selectors VPIM, VOICE, AMIS, and SYSNUM with IANA, the Internet Assigned Numbers Authority. The RFCs define VPIM gateways to "translate between dissimilar environments." Both "onramps" (gateways which connects from another voice mail networking protocol to VPIM) and "offramps" (gateways which connect from VPIM to another voice mail networking protocol) are defined, casting VPIM as the inter-system "highway" that connects the different voice messaging systems together.…

Key claims

No claims recorded.

Discussion questions

  1. Summarise the article in your own words. Which single claim would you verify first, and why?
  2. Which claim in this article is most likely to be revised as the sources update? How would you check its current status?
  3. If two sources disagreed about one of these facts, what would you need in order to trust one over the other?

Bibliography

No sources recorded.

Key claims and bibliography are generated from the same tracked claims and sources as the article page.